Deniland Index - Index was out of range.

  1. 2 years ago


    Hi Guys (and Marcel),

    Having an issue indexing the map of Deniland.

    Have ran through the tutorial on the wiki and done everything right to my knowledge.

    The error I'm getting my RPT file is for the Stratis map AND Deniland is:

    16:39:57 >>>>>>>>>>>>>>>>>> Starting indexing for Stratis map
    16:39:57 >>>>>>>>>>>>>>>>>> Creating a list of objects (excluding blacklist)
    16:39:57 CallExtension loaded: ALiVEClient (C:\ARMA 3\steamapps\common\Arma 3\@ALiVE\ALiVEClient_x64.dll) [] []

    16:39:57 >>>>>>>>>>>>>>>>>> There was a problem, exiting indexing: Index was out of range. Must be non-negative and less than the size of the collection.
    Parameter name: index

    Its exactly the same for both maps. The last line 'index' is the name of the mission incase thats relevant.

    • I've got my module and playable unit down.
    • I've set the system environment path variable twice to something like C:\users\Salad\DeWrp\DeWrp.exe and C:\users\Salad\DeWrp\DeWrp

    Image of module settings:

    Have also tried setting this to 'NO' and also changed to Win 10. With Win 10 I get a message in RPT that says 'DeWrp Error' with no info.

    @AliVE is in my root folder and the scripts folder is in my docs where the wiki said to put it.

    No idea how all this works under the hood but maybe its 1.84 and a new change?

    If you need any more info let me know.

  2. This is probably the exact same issue Vegas was having at Can you post the log that's in the "@ALiVE\indexing\<whatever the name of the map is>" folder? Once I have that we can go through the same steps I did with Vegas and probably get you going. :)

  3. >>>>>>>>>>>>>>>>>> Starting Map Index for stratis on 18/08/2018 16:39:57
    >>>>>>>>>>>>>>>>>> pathToMap: C:\ARMA 3\steamapps\common\Arma 3\Addons\map_stratis.pbo
    >>>>>>>>>>>>>>>>>> root: C:\ARMA 3\steamapps\common\Arma 3\@ALiVE
    >>>>>>>>>>>>>>>>>> folder: C:\ARMA 3\steamapps\common\Arma 3\@ALiVE\indexing
    >>>>>>>>>>>>>>>>>> logfile: C:\ARMA 3\steamapps\common\Arma 3\@ALiVE\indexing\stratis\log.txt
    >>>>>>>>>>>>>>>>>> indexfile: C:\ARMA 3\steamapps\common\Arma 3\@ALiVE\indexing\stratis\x\alive\addons\fnc_strategic\indexes\objects.stratis.sqf
    >>>>>>>>>>>>>>>>>> parsedIndexfile: C:\ARMA 3\steamapps\common\Arma 3\@ALiVE\indexing\stratis\x\alive\addons\fnc_strategic\indexes\parsed.objects.stratis.sqf
    >>>>>>>>>>>>>>>>>> blacklist file: C:\ARMA 3\steamapps\common\Arma 3\@ALiVE\alive_object_blacklist.txt
    Executing deWrp: cmd.exe /c DeWrp.exe -O "C:\ARMA 3\steamapps\common\Arma 3\Addons\map_stratis.pbo" > "C:\ARMA 3\steamapps\common\Arma 3\@ALiVE\indexing\stratis\x\alive\addons\fnc_strategic\indexes\objects.stratis.sqf"
    deWrp analysis completed

    List of objects remaining:

    There ya go Marcel

  4. As per Vegas, both Objects and Parsed.Objects are empty

    Concurrently going to try and download new DeWrp

  5. Edited 2 years ago by marceldev89

    @marceldev89 Alright, then the DeWrp process is failing to do it's thing.

    1. Have you tried switching between Windows 7 and 10 method in the indexing module?
    2. Did you turn off any AV? Antivirus software may interfere with the indexing process because it's happening in Program Files.
    3. Does running DeWrp.exe -O "C:\ARMA 3\steamapps\common\Arma 3\Addons\map_stratis.pbo" from cmd.exe work? Like it should show a list of positions and object names.
    4. Has anything changed on your system since you've last indexed something?

    Cool, I guess you can go through the steps above from that thread. Especially #3 (I've updated the path to yours).

    EDIT: No need to use that DLL I posted in there btw.

  6. Interesting, "DeWrp.exe" is not a recognised command running step 3, I guess my environment variables are wrong then?

  7. Edited 2 years ago by AnAngrySalad

    Marcel, ignore me on this. Step 3 is now working and it's just scrolling through, assume thats expected behaviour?

    EDIT: Got No errors at the end. Have redownloaded DeWrp from wiki, couldn't find it anywhere else. Testing now.

    EDIT 2: Tested, get the same error.

    • No AV running,
    • Swapping to Win after going back to editor and coming back out crashes the game,
    • Going back in and changing to Win 10 gives me a diff error: 18:31:21 >>>>>>>>>>>>>>>>>> There was a problem, exiting indexing: ERROR with deWrp
    • As above, running the command in CMD.exe produces lots of lines with '\\no errors' at the end so assume thats working?
    • Have never indexed before.

    Any other troubleshooting steps?

  8. Hmmm, can you also post the full RPT via pastebin, dropbox or something else along those lines?

  9. Marcel, I'm not going to be around now for a few days so i'll catch up with this on Monday evening.

  10. @marceldev89 Hi Mate, sorry, very busy week with RL and what not. So, got past all the above issues this aft, just started working.

    So currently getting this after starting the index process:

    14:41:31 Warning Message: Script @ALiVE\indexing\deniland\x\alive\addons\fnc_strategic\indexes\objects.deniland.sqf not found

    If I baretail the RPT file it just sits at 'generating sector data'. Its a 40 x 40 map so not sure if its normal to do that?

  11. That error might be solved by switching between the Win 7 and 10 options in the module. It changes the method for redirecting the command output to a file and the fact that it can't find objects.deniland.sqf seems to indicate that that is the issue atm.

  12. Changed that and get the same thing. Can I manually add that file in and make it empty and it'll then populate it? Or is it going to assume the file has content as its there then overlook it and thus not populate it?

  13. Edited 2 years ago by marceldev89

    I mean, you can try. No harm done. ^^

    Do you have the A3 -filePatching parameter enabled?

    EDIT: Actually, just send the entire RPT. It has a lot of useful info about how you're running A3 and all.

  14. Part1:


    This is using my unit mods. Get the same error running ALiVE, CBA, Deniland and CUP (required for Deniland). Whats different this time is i didn't get the error i got before, havent changed anything though so not sure why thats not gone. Been 'generating sector data' for 10mins and no change atm.

  15. Edited 2 years ago by marceldev89

    Oh, I see what the problem is. You need to have @ALiVE in your "Arma 3" folder.

    EDIT: It might be enough to create an empty @ALiVE folder but not sure about that.
    EDIT2: The map your indexing might also have to be in your "Arma 3" folder.

  16. I have both of those in there already, found some page on the forums or wiki that said to do it so i'd already moved it over. Which part says I'm using a different one? I'm thinking it's my setup somehow but I've done everything you're saying and still no joy so think its my end somewhere

  17. latest log

  18. The last log seems to indicate that the module is still pointing to the map on the D drive. Hopefully that will finally get things going. ^^

    23:26:19 Warning: 4280 ms spent in callExtension calling name: "ALiVEClient", function: "StartIndex~D:\ARMA 3\@Deniland\Addons\Deniland.pbo|Deniland|false"
  19. Mornin, thanks for that. I've tried again today and its now pointing to my root arma folder (both alive and Deniland). Everything else (CBA and CUP) is still on D:. I'm not going to leave it for a time as it is a big map.

    If you've got time, can you fill me in on what its actually trying to do when 'generating sector data'? Is it going through every building on the map or every town / city defined in the maps config or something? Just so I can guess how long it might take to do this map (2 minutes or 1 hour etc).

    Thanks for everything you've done so far.

  20. It's basically analyzing the map using the static data you've provided through this building categorization tool thingy. If you turn on debug in the index module you should get a bit more information in the RPT. It might take a while on big maps but I can't really tell you a number but if it takes longer than an hour it probably means something's up. You can check if something is actually happening by checking the files in the @ALiVE\indexing folder and see if anything is being written to those files.

  21. Newer ›

or Sign Up to reply!