Problem setting up persistence on Linux server

  1. 5 years ago

    I have problems setting up persistence, the arma 3 server is running on Ubuntu 14.04.4 LTS (GNU/Linux 4.2.0-34-generic x86_64)

    The server segfaults at the moment it tries to run the @aliveserver plugin, here's the RPT

    And here's the ldd output for the file after installing libcurl3:386 as was explained on another thread:

    $ ldd mods/@aliveserver/
   =>  (0xf7771000)
   => /usr/lib/i386-linux-gnu/ (0xf751e000)
   => /lib/i386-linux-gnu/ (0xf74d8000)
   => /lib/i386-linux-gnu/ (0xf7329000)
            /lib/ (0x56654000)
   => /usr/lib/i386-linux-gnu/ (0xf72f6000)
   => /usr/lib/i386-linux-gnu/ (0xf72db000)
   => /lib/i386-linux-gnu/ (0xf7283000)
   => /lib/i386-linux-gnu/ (0xf70d5000)
   => /usr/lib/i386-linux-gnu/ (0xf708e000)
   => /usr/lib/i386-linux-gnu/ (0xf707f000)
   => /usr/lib/i386-linux-gnu/ (0xf702d000)
   => /lib/i386-linux-gnu/ (0xf7013000)
   => /lib/i386-linux-gnu/ (0xf6ff7000)
   => /usr/lib/i386-linux-gnu/ (0xf6f30000)
   => /lib/i386-linux-gnu/ (0xf6ea9000)
   => /lib/i386-linux-gnu/ (0xf6ea4000)
   => /usr/lib/i386-linux-gnu/ (0xf6de6000)
   => /usr/lib/i386-linux-gnu/ (0xf6db6000)
   => /lib/i386-linux-gnu/ (0xf6db0000)
   => /usr/lib/i386-linux-gnu/ (0xf6da4000)
   => /lib/i386-linux-gnu/ (0xf6d8c000)
   => /usr/lib/i386-linux-gnu/ (0xf6d71000)
   => /usr/lib/i386-linux-gnu/ (0xf6d35000)
   => /usr/lib/i386-linux-gnu/ (0xf6d20000)
   => /usr/lib/i386-linux-gnu/ (0xf6ce4000)
   => /lib/i386-linux-gnu/ (0xf6cdf000)
   => /lib/i386-linux-gnu/ (0xf6cdb000)
   => /usr/lib/i386-linux-gnu/ (0xf6cd2000)
   => /usr/lib/i386-linux-gnu/ (0xf6c4b000)
   => /usr/lib/i386-linux-gnu/ (0xf6ba5000)
   => /usr/lib/i386-linux-gnu/ (0xf6b70000)
   => /usr/lib/i386-linux-gnu/ (0xf6b5a000)
   => /usr/lib/i386-linux-gnu/ (0xf6b53000)
   => /usr/lib/i386-linux-gnu/ (0xf6b29000)
   => /usr/lib/i386-linux-gnu/ (0xf6b1a000)
   => /usr/lib/i386-linux-gnu/ (0xf6ad3000)
   => /usr/lib/i386-linux-gnu/ (0xf6a16000)
   => /lib/i386-linux-gnu/ (0xf69e5000)

    I have tried renaming the file to lowercase but then I get "THERE IS A PROBLEM WITH THE ALIVE PLUGIN!" errors back and no connection to the WarRoom.

    In any case no log is generated by the plugin on the @aliverserver folder.

  2. Tupolov

    25 Mar 2016 Administrator


  3. Hi, I'm back with the tests I ran with the new alive version. Sadly, the server still segfaults whenever I try to use the plugin.

    Stuff that has changed in this two weeks: the server is running now Ubuntu 14.04.4 LTS (GNU/Linux 4.2.0-35-generic x86_64) which is a kernel security upgrade. I'm also now running the latest arma3server linux performance binaries from here:

    I've tried with the normal arma3server binary and it has the same problem, the server crashes when it tries to load the plugin.

    I've ran gdb on the core dump and the output is basically the same as this fellow:

    Our server is really barebones, it just has the core ubuntu server installation, openssh and the libraries needed to operate the arma3server, it runs on an i7 CPU and 12GB of RAM.

    If you guys need more information or tests to be performed I would be happy to oblige. We really like ALiVE and we would *really* like to have persistence working for our missions.

  4. Tupolov

    15 Apr 2016 Administrator

    Us too!

    Our linux plugin dev is away at the moment. We really need him to troubleshoot this.

    Please confirm:

    1. You are testing with ALiVE 1.0.3
    2. You have download the latest version of the plugin
    3. You are testing a vanilla ALiVE Mission - Stratis Quick Start
  5. Ah okay, we'll wait. Meanwhile I can confirm I'm testing with 1.0.3. I've tried with both the version of the plugin included with the 1.0.3 package and the one available in the server setup instructions. And I've tried both a vanilla quickstart mission and a mission with only the core modules loaded, with the same results.

  6. Tupolov

    20 Apr 2016 Administrator
    Edited 5 years ago by Tupolov

    I set up an Ubuntu server for the ALiVE team at the weekend. Everything is working well for us.

    Key things I had to do:

    1. Run ldd to ensure you have all the correct libraries (libcurl3 32bit)
    2. Make sure all pbo's are lowercase for all mods
    3. Copy the mod keys into the arma 3 root keys folder
    4. Make sure that your linux user account running arma 3 is the owner of the arma 3 folder and sub directories
    5. Make sure all pbo's are chmod 755
    6. Make sure the alive server folder is @aliveserver (and not @AliveServer)
    7. Make sure the is NOT all lowercase
    8. Ensure chmod +rw on the (owner is your linux user account for running arma 3)
    9. Check the output of ldd should be:
    steam@BEAST-Ubuntu-1404-trusty-64-minimal:~/steamcmd/arma3/@aliveserver$ ldd
   =>  (0xf7713000)
   => /usr/lib/i386-linux-gnu/ (0xf74bd000)
   => /lib/i386-linux-gnu/ (0xf7477000)
   => /lib/i386-linux-gnu/ (0xf72c8000)
            /lib/ (0xf7714000)
   => /usr/lib/i386-linux-gnu/ (0xf7295000)
   => /usr/lib/i386-linux-gnu/ (0xf727b000)
   => /lib/i386-linux-gnu/ (0xf7223000)
   => /lib/i386-linux-gnu/ (0xf7076000)
   => /usr/lib/i386-linux-gnu/ (0xf7038000)
   => /usr/lib/i386-linux-gnu/ (0xf7029000)
   => /usr/lib/i386-linux-gnu/ (0xf6fd7000)
   => /lib/i386-linux-gnu/ (0xf6fbd000)
   => /lib/i386-linux-gnu/ (0xf6fa1000)
   => /usr/lib/i386-linux-gnu/ (0xf6eda000)
   => /lib/i386-linux-gnu/ (0xf6e54000)
   => /lib/i386-linux-gnu/ (0xf6e4f000)
   => /usr/lib/i386-linux-gnu/ (0xf6d80000)
   => /usr/lib/i386-linux-gnu/ (0xf6d58000)
   => /lib/i386-linux-gnu/ (0xf6d52000)
   => /usr/lib/i386-linux-gnu/ (0xf6d49000)
   => /lib/i386-linux-gnu/ (0xf6d31000)
   => /usr/lib/i386-linux-gnu/ (0xf6d15000)
   => /usr/lib/i386-linux-gnu/ (0xf6cd9000)
   => /usr/lib/i386-linux-gnu/ (0xf6cc4000)
   => /usr/lib/i386-linux-gnu/ (0xf6cb2000)
   => /lib/i386-linux-gnu/ (0xf6cad000)
   => /lib/i386-linux-gnu/ (0xf6ca9000)
   => /usr/lib/i386-linux-gnu/ (0xf6ca0000)
   => /usr/lib/i386-linux-gnu/ (0xf6c19000)
   => /usr/lib/i386-linux-gnu/ (0xf6b73000)
   => /usr/lib/i386-linux-gnu/ (0xf6b3e000)
   => /usr/lib/i386-linux-gnu/ (0xf6b28000)
   => /usr/lib/i386-linux-gnu/ (0xf6aff000)
   => /usr/lib/i386-linux-gnu/ (0xf6aef000)
   => /usr/lib/i386-linux-gnu/ (0xf6aa8000)
   => /usr/lib/i386-linux-gnu/ (0xf69eb000)
   => /lib/i386-linux-gnu/ (0xf69ba000)
  7. Deleted 5 years ago by hell
  8. Well, all is OK according to your checklist. I usually have the pbo files with 644 file permissions since I don't think the arma3server requires execute permissions for pbo's but I still went and made the change to 755. And I even went and changed the @aliveserver directory and file permissions to 777 and 666 and still no joy.

    The only difference I noticed was on the ldd output where you have this:

   => /usr/lib/i386-linux-gnu/ (0xf6b28000)
   => /usr/lib/i386-linux-gnu/ (0xf6aff000)

    And I have this:

   => /usr/lib/i386-linux-gnu/ (0xf6b50000)
   => /usr/lib/i386-linux-gnu/ (0xf6b49000)
   => /usr/lib/i386-linux-gnu/ (0xf6b1f000)
  9. Tupolov

    21 Apr 2016 Administrator

    Man, I don't know what to say. Our Ubuntu server works just fine. Could it be the kernel security upgrades are causing the segfault?

    the libffi is weird. Here's the version of the plugin we are using:

  10. Thanks man, I just tried with the file you linked and the same thing happened.

    I'm guessing it's a weird configuration issue but I'm really stumped at what might be causing it. And I know it might be next to impossible to fix if you can't reproduce it but I still thank you for your support. I'll keep trying to figure it out in the meantime.

  11. Tupolov

    21 Apr 2016 Administrator

    I'm building a new version of the plugin for the next release. Doubt it will change things, but might work!

  12. Thanks! I'll try the next version for sure. Maybe I'll try to set it up on another distro and see if it's something to do with ubuntu in particular or a PEBKAC.

  13. Tupolov

    21 Apr 2016 Administrator

    New linux plugin (2.1) pushed to above link. 1.0.4 ALiVE inbound over the next 1 hour or two :)

  14. Thanks man, I tried again with the new plugin and got the exact same problem. I'm going to install debian instead of ubuntu and try again, I hope it's something specific to this installation/distro combo and that the switch to debian solves it. I will report back with my results (congrats on the new release, btw)

  15. Tupolov

    22 Apr 2016 Administrator

    Someone just pointed out that the plugin REQUIRES 32bit version of libcurl...

  16. Ah yes, it was one of the first things I found out thanks to this thread:


  17. Hi, I'm back with some information. I have segfaults again with Debian "Jessie". With this I'm almost sure it is hardware related. But I can't pinpoint to something specific so I guess I'll have to hunt it down some more, either by using a non Debian-based distro or experimenting with older distros. I thank you for your help Tupolov and I'll try to come back and update if I ever find out a good explanation to this issue.

  18. Edited 5 years ago by marceldev89

    Ran into the same problem on my Debian Jessie server today.. Been trying to debug this thing with gdb, strace, ltrace and what not for the better part of the day. Then I figured I'd try a reboot and things magically started working..

    I'll try to figure out what and why it happened but as far as I know libcurl3:i386 is the only package I installed that could be related to this and the output of ldd was fine before the reboot.

  19. Well, it does seem that all I needed was a reboot (or running ldconfig, if it was actually related to libraries). Also, @aliveserver MUST be located (or as a symlink) in the root, the server will crash if it's not (it can't create the log files, which doesn't seem to be handled properly)...


or Sign Up to reply!